MapStructFields
? Since the only operations its implementing classes do is to add fields based on some criteria, matching what map
does to an iterator. Or FieldMapper
.
I would suggest naming it llvm_type
. Use of get_
is discouraged in Rust AFAIK.
Move this into the documentation for their respective functions. It is very difficult to refer to these examples when you are trying to look for how to use the APIs.
Are there any types in Model
that distinguishes between an array alloca and alloca? I think it would be preferable to have something like an ArrayPtr
to replace the type of an ArraySliceValue
.
Thanks. You could squash the final few commits and then we can merge it.
Switched to your .clang-format and reformatted everything. How see?
Much better.
Do you want me to help you do a quick rebase pass to fix all the formatting issues instead?
The positions of pointers *
and references &
are still incorrect, and I still see many uses of C-style casts. Please change those before submitting for re-review.